summaryrefslogtreecommitdiffstats
path: root/src/corelib/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2017-05-02 19:23:13 +0200
committerFabian Kosmale <fabian.kosmale@qt.io>2020-03-17 10:01:04 +0100
commit165de1002719175c75df61913d36c2189538a84b (patch)
tree39f3be146633ad2f25b1a55d000edb1475149082 /src/corelib/CMakeLists.txt
parent7ef382649754c261ca9eb99dd50b67050e748efb (diff)
Introduce helper class QTaggedPointer
Useful for attaching small bits of information in the alignment bits of a naked pointer. For use in the new property system as well as in qtdeclarative (where currently a similar class exists as private API). Change-Id: Idf9b93e714e15129f302e16425dbeda94bcd207b Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/corelib/CMakeLists.txt')
-rw-r--r--src/corelib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/corelib/CMakeLists.txt b/src/corelib/CMakeLists.txt
index 0435a7a4fc..e28df10290 100644
--- a/src/corelib/CMakeLists.txt
+++ b/src/corelib/CMakeLists.txt
@@ -230,6 +230,7 @@ qt_add_module(Core
tools/qsimd.cpp tools/qsimd_p.h
tools/qsize.cpp tools/qsize.h
tools/qstack.h
+ tools/qtaggedpointer.h
tools/qtools_p.h
tools/qvarlengtharray.h
tools/qvector.h