summaryrefslogtreecommitdiffstats
path: root/src/corelib/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Mutz <marc.mutz@kdab.com>2021-07-16 09:57:56 +0200
committerMarc Mutz <marc.mutz@kdab.com>2021-07-28 17:50:09 +0200
commit3a72496b5c43484a94882440993b0ca0cb842d8a (patch)
tree7704812d37e34a0e3e6ab32e17bb8a7624b3828d /src/corelib/CMakeLists.txt
parent74a91773afa395ee0cefcdcd25bb3947b60a0b63 (diff)
tests: fix some -Wvolatile
C++20 deprecated compound volatile statements such as pre- and post-increments, to stress that they're not atomic. So instead of volatile i; ~~~~; ++i; you're now supposed to write volatile i; ~~~~; int j = i; // volatile load ++j; i = j; // volatile store which matches more closely what hardware does. Instead of fixing every use of volatile pre- or post-increment in this fashion individually, and realising that probably a few more Qt modules will have the same kind of code patterns in them, write QtPrivate functions to do the job centrally. Change-Id: I838097bd484ef2118c071726963f103c080d2ba5 Reviewed-by: Lars Knoll <lars.knoll@qt.io>
Diffstat (limited to 'src/corelib/CMakeLists.txt')
-rw-r--r--src/corelib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/corelib/CMakeLists.txt b/src/corelib/CMakeLists.txt
index db261d33cc..b77cf35b92 100644
--- a/src/corelib/CMakeLists.txt
+++ b/src/corelib/CMakeLists.txt
@@ -60,6 +60,7 @@ qt_internal_add_module(Core
global/qsysinfo.h
global/qsystemdetection.h
global/qtypeinfo.h
+ global/qvolatile_p.h
io/qabstractfileengine.cpp io/qabstractfileengine_p.h
io/qbuffer.cpp io/qbuffer.h
io/qdataurl.cpp io/qdataurl_p.h