summaryrefslogtreecommitdiffstats
path: root/src/corelib/CMakeLists.txt
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2021-04-14 14:00:20 +0200
committerUlf Hermann <ulf.hermann@qt.io>2021-04-16 16:49:28 +0200
commit57850f9d6d6cf2d745cdfcdecb4b55cd9088b898 (patch)
treee2f3c09095f250a8f28bd63398200351a46f90b5 /src/corelib/CMakeLists.txt
parent07d4a981a23665ea8206a2faf6e0c99e8bf2052c (diff)
Switch metatypes generation on by default for Qt modules
We need the metatypes for anything directly or indirectly exposed to QML. Switching this on has no runtime overhead. For interface libraries we cannot generate any metatypes, though. Change-Id: I7b7f85bb4e16c28d00383c5c88b0f1c172c8d193 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'src/corelib/CMakeLists.txt')
-rw-r--r--src/corelib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/corelib/CMakeLists.txt b/src/corelib/CMakeLists.txt
index 3b4fdd1b46..2af8854798 100644
--- a/src/corelib/CMakeLists.txt
+++ b/src/corelib/CMakeLists.txt
@@ -32,6 +32,7 @@ endif()
qt_internal_add_module(Core
QMAKE_MODULE_CONFIG moc resources
+ NO_GENERATE_METATYPES # metatypes are extracted manually below
EXCEPTIONS
SOURCES
global/archdetect.cpp