summaryrefslogtreecommitdiffstats
path: root/src/corelib/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Mutz <marc.mutz@qt.io>2021-12-19 18:37:19 +0100
committerMarc Mutz <marc.mutz@qt.io>2021-12-20 13:32:28 +0100
commit620220413e7b5d838fca1e56a0dc3a3a7135dcba (patch)
tree60834517aa54445ca133eafeefb01d21e56ff294 /src/corelib/CMakeLists.txt
parent87b93c29be02f0a7ff9424b5e2b6431e20bd4c40 (diff)
CMake: don't treat Q_CORE_EXPORT special
Let CMake create a qtcoreexports.h just like for every other Qt library, include it in a fitting place in qglobal.h. Currently, that's in the middle of the file, but that will be cleaned up in subsequent commits. Task-number: QTBUG-99313 Change-Id: I3ea9f4772b0ad63c7e8431689146cac3336c5ccf Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io> Reviewed-by: Alexey Edelev <alexey.edelev@qt.io>
Diffstat (limited to 'src/corelib/CMakeLists.txt')
-rw-r--r--src/corelib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/corelib/CMakeLists.txt b/src/corelib/CMakeLists.txt
index 915a7ae08c..c1259150ab 100644
--- a/src/corelib/CMakeLists.txt
+++ b/src/corelib/CMakeLists.txt
@@ -266,6 +266,7 @@ qt_internal_add_module(Core
Qt::GlobalConfigPrivate # special case
PRECOMPILED_HEADER
"global/qt_pch.h"
+ GENERATE_CPP_EXPORTS
PUBLIC_LIBRARIES # special case:
Qt::Platform # special case:
# special case begin