summaryrefslogtreecommitdiffstats
path: root/src/corelib/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2021-03-15 14:25:34 +0100
committerAlexey Edelev <alexey.edelev@qt.io>2021-03-17 11:57:11 +0100
commit6fb569af9512f63d503720ed7f62e9c70b16f969 (patch)
tree7a49c1fa32c064aeaefaa9ebec2c695c2fa275ad /src/corelib/CMakeLists.txt
parenta423c0d21174fc88a02277d9cd909b0d6e11018b (diff)
Unify QLibraryInfo settings
Exporting QLibraryInfo internals allows to reuse settings in qmake/qtpath without having to keep its own instance. Also there is no need to check setting groups in QLibraryInfo except the 'Paths' group, since this logic belongs to qmake/qtpaths only. Change-Id: If762defba025ad7f7489f8a86ef5768a8628bd2f Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/corelib/CMakeLists.txt')
-rw-r--r--src/corelib/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/corelib/CMakeLists.txt b/src/corelib/CMakeLists.txt
index 09ef97f47f..04c2cc1881 100644
--- a/src/corelib/CMakeLists.txt
+++ b/src/corelib/CMakeLists.txt
@@ -41,7 +41,7 @@ qt_internal_add_module(Core
global/qglobal.cpp global/qglobal.h
global/qglobalstatic.h
global/qhooks.cpp global/qhooks_p.h
- global/qlibraryinfo.cpp global/qlibraryinfo.h
+ global/qlibraryinfo.cpp global/qlibraryinfo.h global/qlibraryinfo_p.h
global/qlogging.cpp global/qlogging.h
global/qmalloc.cpp
# global/qnamespace.h # special case