summaryrefslogtreecommitdiffstats
path: root/src/corelib/CMakeLists.txt
diff options
context:
space:
mode:
authorNiclas Rosenvik <nros@netbsd.org>2021-03-20 09:31:43 +0000
committerNiclas Rosenvik <nros@netbsd.org>2021-03-22 21:31:09 +0000
commit75296f347f2781fff44f8fcfea5a3fa0413e287e (patch)
treed1bdd58263f0e28d600c0b382e7e03eb250859c5 /src/corelib/CMakeLists.txt
parent65b4937f341134fbb1082050b7ae8ecf5c0ba564 (diff)
Fix backtrace on non-linux systems
On BSD systems backtrace lies in libexecinfo. Use FindBacktrace from CMake to be able to resolve backtrace on more unixes than linux. Change-Id: Ie14fd1727d2da03645fc2d6de10c0217baabad6b Reviewed-by: Edward Welbourne <edward.welbourne@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
Diffstat (limited to 'src/corelib/CMakeLists.txt')
-rw-r--r--src/corelib/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/corelib/CMakeLists.txt b/src/corelib/CMakeLists.txt
index ab73d8b98c..95c3116753 100644
--- a/src/corelib/CMakeLists.txt
+++ b/src/corelib/CMakeLists.txt
@@ -729,6 +729,11 @@ qt_internal_extend_target(Core CONDITION QT_FEATURE_commandlineparser
tools/qcommandlineparser.cpp tools/qcommandlineparser.h
)
+qt_internal_extend_target(Core CONDITION QT_FEATURE_backtrace
+ LIBRARIES
+ WrapBacktrace::WrapBacktrace
+)
+
qt_internal_extend_target(Core CONDITION QT_FEATURE_system_doubleconversion
LIBRARIES
WrapDoubleConversion::WrapDoubleConversion