summaryrefslogtreecommitdiffstats
path: root/src/corelib/CMakeLists.txt
diff options
context:
space:
mode:
authorThiago Macieira <thiago.macieira@intel.com>2021-11-14 10:08:21 -0800
committerThiago Macieira <thiago.macieira@intel.com>2021-11-19 22:51:03 -0800
commit892d5607d0b1c9e010ea10a1123e68741c46c21e (patch)
treee23b8ba93194383cede7da24b3409a24f9c795ca /src/corelib/CMakeLists.txt
parent235173175b64ea4a5571373a4c37c35b4e18d14f (diff)
QPluginLoader: add COFF PE file parser
Fixes: QTBUG-67461 Docs: https://docs.microsoft.com/en-us/windows/win32/debug/pe-format Change-Id: I5e52dc5b093c43a3b678fffd16b77bf9a8f2b17e Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: MÃ¥rten Nordheim <marten.nordheim@qt.io>
Diffstat (limited to 'src/corelib/CMakeLists.txt')
-rw-r--r--src/corelib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/corelib/CMakeLists.txt b/src/corelib/CMakeLists.txt
index a14239e9ae..cd79a9f0c2 100644
--- a/src/corelib/CMakeLists.txt
+++ b/src/corelib/CMakeLists.txt
@@ -1017,6 +1017,7 @@ qt_internal_extend_target(Core CONDITION QT_FEATURE_library
)
qt_internal_extend_target(Core CONDITION QT_FEATURE_library AND WIN32
SOURCES
+ plugin/qcoffpeparser.cpp plugin/qcoffpeparser_p.h
plugin/qlibrary_win.cpp
)
qt_internal_extend_target(Core CONDITION QT_FEATURE_library AND APPLE