summaryrefslogtreecommitdiffstats
path: root/src/corelib/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Mutz <marc.mutz@kdab.com>2021-08-27 17:07:54 +0200
committerMarc Mutz <marc.mutz@qt.io>2021-11-04 16:11:36 +0000
commitb4c7d6b8d4b33bb1f496b288f7d199037326cd18 (patch)
tree7ce1bd312c5ed9061e3f25cd049b5cdda6ccb888 /src/corelib/CMakeLists.txt
parent404a7c00943ffaf3175744570f46441fa0d99b8b (diff)
Extract Header qbindingstorage.h
QBindingStorage doesn't depend in-size on much else in qproperty.h, but is used in-size in qobject.h, thus requiring qobject.h to include qproperty.h. As a first step, move the class and the bits it actually depends on, to a separate header file, qbindingstorage.h, and, for now, just include that from qproperty.h. The end goal here is to make qobject.h independent of qproperty.h. Pick-to: 6.2 Change-Id: I44245a5e57473067e3106d1fd70bf2d744ce0a5f Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/corelib/CMakeLists.txt')
-rw-r--r--src/corelib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/corelib/CMakeLists.txt b/src/corelib/CMakeLists.txt
index 0301acfa97..c8c51e4a8b 100644
--- a/src/corelib/CMakeLists.txt
+++ b/src/corelib/CMakeLists.txt
@@ -101,6 +101,7 @@ qt_internal_add_module(Core
kernel/qabstractnativeeventfilter.cpp kernel/qabstractnativeeventfilter.h
kernel/qassociativeiterable.cpp kernel/qassociativeiterable.h
kernel/qbasictimer.cpp kernel/qbasictimer.h
+ kernel/qbindingstorage.h
kernel/qcoreapplication.cpp kernel/qcoreapplication.h kernel/qcoreapplication_p.h
kernel/qcoreapplication_platform.h
kernel/qcorecmdlineargs_p.h