summaryrefslogtreecommitdiffstats
path: root/src/corelib/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Hausmann <simon.hausmann@qt.io>2019-10-14 15:54:02 +0200
committerSimon Hausmann <simon.hausmann@qt.io>2019-10-14 14:38:48 +0000
commitdcb1253d931942ebb4ec16bbe843941e25df5aff (patch)
treee4f9b70940d0cbc363a129645811f4081712159a /src/corelib/CMakeLists.txt
parentb2662b05dd078c46b82f5f041f51b0b83554113d (diff)
Fix up android architecture suffixing
Don't globally map any variable use of QT_ARCH to ANDROID_ABI, as that'll break if somebody uses it in a different context. Instead the CMAKE_SYSTEM_PROCESSOR variable provides a reasonable value and it is also set by the Android toolchain files. Change-Id: Ibf203c39db586bbec5b800a365d83b3a509dbb62 Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/corelib/CMakeLists.txt')
-rw-r--r--src/corelib/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/corelib/CMakeLists.txt b/src/corelib/CMakeLists.txt
index e263df82d0..5be57fab8f 100644
--- a/src/corelib/CMakeLists.txt
+++ b/src/corelib/CMakeLists.txt
@@ -399,7 +399,7 @@ extend_target(Core CONDITION ANDROID
kernel/qsharedmemory_android.cpp
kernel/qsystemsemaphore_android.cpp
DEFINES
- LIBS_SUFFIX="\\\\"_${ANDROID_ABI}.so\\\\"" # special case
+ LIBS_SUFFIX="\\\\"_${CMAKE_SYSTEM_PROCESSOR}.so\\\\"" # special case
)
extend_target(Core CONDITION MSVC AND (TEST_architecture_arch STREQUAL "i386")
@@ -514,7 +514,7 @@ extend_target(Core CONDITION INTEGRITY
#### Keys ignored in scope 21:.:global:global/global.pri:CLANG OR intel_icl OR ICC:
# f16c_cxx = "false"
-#### Keys ignored in scope 23:.:global:global/global.pri:GCC AND f16c AND x86SimdAlways:
+#### Keys ignored in scope 23:.:global:global/global.pri:GCC AND f16c AND TEST_architecture_arch STREQUAL x86imdAlways:
# f16c_cxx = "true"
#### Keys ignored in scope 25:.:global:global/global.pri:MSVC AND QT_CPU_FEATURES__ss_QT_ARCH___contains___avx: