summaryrefslogtreecommitdiffstats
path: root/src/corelib/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Mutz <marc.mutz@kdab.com>2021-07-05 20:10:07 +0200
committerMarc Mutz <marc.mutz@kdab.com>2021-07-06 16:30:52 +0200
commitde18b3ff370543b5b99bd068b871a2cd677cf9f3 (patch)
tree2cd67bd934657e2ce92a08af00e73e604d86f02b /src/corelib/CMakeLists.txt
parent85831bcfe6ce36740c524d641ada79c65aadd89b (diff)
QCryptographicHash: port addData() to QByteArrayView
Incl. the static hash() function. Remove the QByteArray versions from the API, but not the ABI. Adapt some callers. [ChangeLog][QtCore][QCryptographicHash] Replaced QByteArray with QByteArrayView in addData() and static hash() functions. Change-Id: Ia0e9bf726276305e05894d323d76a29e985f39eb Reviewed-by: Lars Knoll <lars.knoll@qt.io>
Diffstat (limited to 'src/corelib/CMakeLists.txt')
-rw-r--r--src/corelib/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/corelib/CMakeLists.txt b/src/corelib/CMakeLists.txt
index 767768f29c..9023e24dd2 100644
--- a/src/corelib/CMakeLists.txt
+++ b/src/corelib/CMakeLists.txt
@@ -241,6 +241,7 @@ qt_internal_add_module(Core
tools/qsize.cpp tools/qsize.h
tools/qstack.h
tools/qtaggedpointer.h
+ tools/qtcore_tools_removed_functions_in_6_3.cpp
tools/qtools_p.h
tools/qvarlengtharray.h
tools/qvector.h
@@ -271,7 +272,14 @@ qt_internal_add_module(Core
# special case end
)
-qt_update_ignore_pch_source(Core kernel/qmetatype.cpp )
+set(corelib_no_pch_sources
+ kernel/qmetatype.cpp
+ tools/qtcore_tools_removed_functions_in_6_3.cpp
+)
+
+foreach(src ${corelib_no_pch_sources})
+ qt_update_ignore_pch_source(Core ${src})
+endforeach()
# special case begin
add_dependencies(Core qmodule_pri)