summaryrefslogtreecommitdiffstats
path: root/src/corelib/CMakeLists.txt
diff options
context:
space:
mode:
authorFabian Kosmale <fabian.kosmale@qt.io>2021-03-25 13:59:55 +0100
committerFabian Kosmale <fabian.kosmale@qt.io>2021-03-26 09:26:51 +0100
commite05d666d42dcda1fb97cec7039130ee118044c12 (patch)
tree411c598de4f9e1bc98a3db9dd71c1175f4a59fc1 /src/corelib/CMakeLists.txt
parent547228bf86281733c09a0638c57a4384c664f66e (diff)
QMetaType::id(): Fix ABI breakage
We cannot replace a non-inline method with an inline one without breaking the ABI. Instead, we now create a version with a dummy int parameter (to avoid ODR violations), and hide the non-inline version behind an ifdef, so that it is only visible in qmetatype.cpp. Pick-to: 6.1 Change-Id: Ib4e82e44071bdf5c37227409a56d377ff2e07ee0 Reviewed-by: MÃ¥rten Nordheim <marten.nordheim@qt.io> Reviewed-by: Ulf Hermann <ulf.hermann@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'src/corelib/CMakeLists.txt')
-rw-r--r--src/corelib/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/corelib/CMakeLists.txt b/src/corelib/CMakeLists.txt
index d8baa4952b..1a9a690f42 100644
--- a/src/corelib/CMakeLists.txt
+++ b/src/corelib/CMakeLists.txt
@@ -264,6 +264,8 @@ qt_internal_add_module(Core
# special case end
)
+qt_update_ignore_pch_source(Core kernel/qmetatype.cpp )
+
# special case begin
add_dependencies(Core qmodule_pri)
add_dependencies(Core ${QT_CMAKE_EXPORT_NAMESPACE}::moc)