summaryrefslogtreecommitdiffstats
path: root/src/corelib/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2021-07-22 14:34:38 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-07-26 16:11:02 +0000
commitedebb8c6cc93274bc5b6e3aba5199b570323963a (patch)
treef6a1b7292286c0daa0856eb4bfbdfcae1dab9213 /src/corelib/CMakeLists.txt
parent25ca17c20ac7353a4e1c196916a0476e5ed30d32 (diff)
Move Android implementation of permissions API to QtAndroidPrivate
And remove plumbing from public QCoreApplication API, which is going to be removed in follow up patch after leaf modules have moved to the private Android API. The public permissions API will be reintroduced in 6.3 after further work. Change-Id: I46772284b98d0ced8d4a624a850adaa4a1dfe645 Reviewed-by: Assam Boudjelthia <assam.boudjelthia@qt.io> (cherry picked from commit 5604f633c06585246ba473b209c35db67d68740c) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'src/corelib/CMakeLists.txt')
-rw-r--r--src/corelib/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/corelib/CMakeLists.txt b/src/corelib/CMakeLists.txt
index df46c3716c..b3f9085162 100644
--- a/src/corelib/CMakeLists.txt
+++ b/src/corelib/CMakeLists.txt
@@ -973,7 +973,6 @@ qt_internal_extend_target(Core CONDITION UNIX AND NOT APPLE
qt_internal_extend_target(Core CONDITION ANDROID AND NOT ANDROID_EMBEDDED
SOURCES
io/qstandardpaths_android.cpp
- kernel/qcoreapplication_android.cpp
io/qstorageinfo_unix.cpp
kernel/qjnienvironment.cpp kernel/qjnienvironment.h
kernel/qjniobject.cpp kernel/qjniobject.h