summaryrefslogtreecommitdiffstats
path: root/src/dbus/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-05-07 19:46:57 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-05-08 12:32:53 +0000
commit0efe6fc90fe964b8be20ca2046e3bfe7a394f3f7 (patch)
treef95d62707d891dcba92d0dbb86dc6113b4678a6e /src/dbus/CMakeLists.txt
parent0c498ef4ffde8c410ee2d34ef977779e22070122 (diff)
Don't link against dbus-1_nolink when dbus_linked feature is off
dbus1_linked is only evaluated to true when the dbus package is found. If it was not found, then it makes no sense to link against the _nolink target, because no package was found in the first place. When the package is not found, QtDBus uses a minimal dbus header which is included with QtDBus sources, so there is no need for the _nolink target. This amends cc141cc5c61d086d6938e2c7312ec02e5f79734c and fixes a build failure on macOS. Change-Id: I71dcbb7465ad13b0bf03579f51412c373125caba Reviewed-by: Tobias Hunger <tobias.hunger@qt.io>
Diffstat (limited to 'src/dbus/CMakeLists.txt')
-rw-r--r--src/dbus/CMakeLists.txt10
1 files changed, 1 insertions, 9 deletions
diff --git a/src/dbus/CMakeLists.txt b/src/dbus/CMakeLists.txt
index 09fcdfd255..4768460e05 100644
--- a/src/dbus/CMakeLists.txt
+++ b/src/dbus/CMakeLists.txt
@@ -60,18 +60,10 @@ set_source_files_properties(qdbusmarshaller.cpp
extend_target(DBus CONDITION QT_FEATURE_dbus_linked
DEFINES
QT_LINKED_LIBDBUS
- PUBLIC_LIBRARIES # special case
+ LIBRARIES
dbus-1
)
-# begin special case:
-extend_target(DBus CONDITION NOT QT_FEATURE_dbus_linked
- PUBLIC_LIBRARIES
- dbus-1_nolink
-)
-# end special case:
-
-
extend_target(DBus CONDITION WIN32
LIBRARIES
advapi32