summaryrefslogtreecommitdiffstats
path: root/src/dbus/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-05-06 14:39:36 +0200
committerTobias Hunger <tobias.hunger@qt.io>2019-05-06 14:22:36 +0000
commit42648ff99310db6ce8e94c5dea9db16a6454232f (patch)
treecb9b809645b25eba907da923b2c72d7ea4c59a15 /src/dbus/CMakeLists.txt
parent059f4ade7fd08b782ecb888f8ee9f0e553c07e9a (diff)
CMake: Regenerate src/dbus
Change-Id: Iff9890ead883bac5f75425a2d0367e639d648399 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/dbus/CMakeLists.txt')
-rw-r--r--src/dbus/CMakeLists.txt16
1 files changed, 9 insertions, 7 deletions
diff --git a/src/dbus/CMakeLists.txt b/src/dbus/CMakeLists.txt
index d17667a26a..4768460e05 100644
--- a/src/dbus/CMakeLists.txt
+++ b/src/dbus/CMakeLists.txt
@@ -44,14 +44,15 @@ add_qt_module(DBus
LIBRARIES
Qt::CorePrivate
PUBLIC_LIBRARIES
- Qt::Core # special case
- # MODULE_CONFIG = "dbusadaptors" "dbusinterfaces"
- # _LOADED = "qt_module"
+ Qt::Core
)
set_source_files_properties(qdbusmarshaller.cpp
PROPERTIES HEADER_FILE_ONLY ON) # special case: This file is included by qdbusargument.cpp
+#### Keys ignored in scope 1:.:.:dbus.pro:<TRUE>:
+# MODULE_CONFIG = "dbusadaptors" "dbusinterfaces"
+# _LOADED = "qt_module"
## Scopes:
#####################################################################
@@ -60,15 +61,16 @@ extend_target(DBus CONDITION QT_FEATURE_dbus_linked
DEFINES
QT_LINKED_LIBDBUS
LIBRARIES
- dbus
+ dbus-1
)
extend_target(DBus CONDITION WIN32
LIBRARIES
- ws2_32
advapi32
netapi32
user32
+ ws2_32
+)
+add_qt_docs(
+ doc/qtdbus.qdocconf
)
-
-add_qt_docs(./doc/qtdbus.qdocconf)