summaryrefslogtreecommitdiffstats
path: root/src/dbus/CMakeLists.txt
diff options
context:
space:
mode:
authorGiuseppe D'Angelo <giuseppe.dangelo@kdab.com>2023-07-03 23:16:18 +0200
committerGiuseppe D'Angelo <giuseppe.dangelo@kdab.com>2023-07-11 22:44:29 +0200
commit536a4299be21137f73649173416161bb554bc07f (patch)
tree3a9c4df15d1dab73910311551d5b10dd20ad10dd /src/dbus/CMakeLists.txt
parentb476570932dcfc1b32e8405bcdd219c2dcc421f7 (diff)
Enable QT_NO_CONTEXTLESS_CONNECT for most of QtBase
It's clean now, keep it as such. Enabling it for QtCore is still OK, because it just hides a function template declared in a header. Change-Id: I8e7dfae179732ba04241a6a3258c2d722e8259df Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
Diffstat (limited to 'src/dbus/CMakeLists.txt')
-rw-r--r--src/dbus/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/dbus/CMakeLists.txt b/src/dbus/CMakeLists.txt
index f489eac2e3..1ce8becb54 100644
--- a/src/dbus/CMakeLists.txt
+++ b/src/dbus/CMakeLists.txt
@@ -42,6 +42,7 @@ qt_internal_add_module(DBus
qtdbusglobal.h qtdbusglobal_p.h
DEFINES
DBUS_API_SUBJECT_TO_CHANGE
+ QT_NO_CONTEXTLESS_CONNECT
QT_NO_FOREACH
LIBRARIES
Qt::CorePrivate