summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2022-05-13 11:29:43 +0200
committerAlexey Edelev <alexey.edelev@qt.io>2022-05-13 20:06:40 +0200
commit28b4bd7dbbd4c0d4e2e04aff0ff885ec163975bc (patch)
treef5fb9bea33069c342a2bd199b444b3ee44d95ea5 /src/gui/CMakeLists.txt
parent601dbd64993fcbbb2ce6aaa95ef153ffd4f852b9 (diff)
Use correct condition for the qopengles2ext.h file
Amends b98706f12207112645cc02a6df4868ebda2db8be Change-Id: I5d7af699d0afed4deebc5afd39725f1af68833b5 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index d5d35975b3..0ff1ef0c94 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -837,12 +837,16 @@ qt_internal_extend_target(Gui CONDITION QT_FEATURE_undogroup
qt_internal_extend_target(Gui CONDITION QT_FEATURE_opengl AND QT_FEATURE_xlib AND NOT QT_FEATURE_opengles2
SOURCES
- opengl/qopengles2ext.h
opengl/platform/unix/qglxconvenience.cpp opengl/platform/unix/qglxconvenience_p.h
LIBRARIES
X11::X11
)
+qt_internal_extend_target(Gui CONDITION QT_FEATURE_opengles2
+ SOURCES
+ opengl/qopengles2ext.h
+)
+
qt_internal_extend_target(Gui CONDITION QT_FEATURE_egl AND QT_FEATURE_opengl
SOURCES
opengl/platform/egl/qeglpbuffer.cpp opengl/platform/egl/qeglpbuffer_p.h