summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorAllan Sandfeld Jensen <allan.jensen@qt.io>2020-10-29 12:47:15 +0100
committerAllan Sandfeld Jensen <allan.jensen@qt.io>2020-10-29 14:20:03 +0100
commit4c36d64bb3a4425848de3f134a8caca3e8d20fe3 (patch)
treefd99d7c1bcdacb779b0d31098058ff6380617756 /src/gui/CMakeLists.txt
parent30a1683f65fa0d01eceb7e1293abc84108d76e7f (diff)
You can't disable SSE2 for x86-64
Fixes: QTBUG-88013 Change-Id: Iec571ef3fccbec46145617ca8d983c3a333090e4 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt15
1 files changed, 11 insertions, 4 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index e503eb6a88..a7c0006bb9 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -567,10 +567,17 @@ qt_internal_extend_target(Gui CONDITION ((QT_FEATURE_png) AND (WIN32 AND MINGW))
)
if(NOT ANDROID)
- qt_internal_add_simd_part(Gui SIMD sse2
- SOURCES
- painting/qdrawhelper_sse2.cpp
- )
+ if(TEST_architecture_arch STREQUAL x86_64)
+ qt_internal_extend_target(Gui
+ SOURCES
+ painting/qdrawhelper_sse2.cpp
+ )
+ else()
+ qt_internal_add_simd_part(Gui SIMD sse2
+ SOURCES
+ painting/qdrawhelper_sse2.cpp
+ )
+ endif()
qt_internal_add_simd_part(Gui SIMD ssse3
SOURCES