summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Hausmann <simon.hausmann@qt.io>2019-11-11 13:52:21 +0100
committerSimon Hausmann <simon.hausmann@qt.io>2019-11-11 13:04:35 +0000
commit52345a1076dcd09a6439bb16850d7f0fd4fad237 (patch)
treef5e7818010c859aa52a6a43e9062e89845e57cd9 /src/gui/CMakeLists.txt
parent1b41a62893e33c1be8e1103da9eb201ce392be09 (diff)
Fix cross-compilation against sysroot with vulkan support
Replace the use of the unqualified qvkgen target with the fully qualified one, as we can be sure that that target exists during a host build as well as when cross-compiling. Change-Id: I31ce3d9f2fd629668a275da9114ab55339b82c31 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index 6a62fa233c..79c3d34aee 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -717,11 +717,6 @@ extend_target(Gui CONDITION QT_FEATURE_vulkan
# special case begin
if (QT_FEATURE_vulkan)
- set(qvkgen_command "${HOST_QVKGEN}")
- if (TARGET qvkgen)
- set(qvkgen_command qvkgen)
- endif()
-
set(vulkan_fun "qvulkanfunctions.h")
set(vulkan_fun_p "qvulkanfunctions_p.h")
set(vulkan_fun_p_cpp "qvulkanfunctions_p.cpp")
@@ -729,7 +724,7 @@ if (QT_FEATURE_vulkan)
add_custom_command(
OUTPUT "vulkan/${vulkan_fun}" "vulkan/${vulkan_fun_p}" "vulkan/${vulkan_fun_p_cpp}"
COMMAND "${CMAKE_COMMAND}" -E make_directory "${CMAKE_CURRENT_BINARY_DIR}/vulkan/"
- COMMAND "${qvkgen_command}"
+ COMMAND ${QT_CMAKE_EXPORT_NAMESPACE}::qvkgen
"${CMAKE_CURRENT_SOURCE_DIR}/vulkan/vk.xml"
"${PROJECT_SOURCE_DIR}/header.LGPL"
"${CMAKE_CURRENT_BINARY_DIR}/vulkan/qvulkanfunctions"