summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2020-06-15 10:54:00 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2020-06-18 12:02:26 +0200
commit7e83f09eadc54fb3a9ae89598a42b7dc0aa2828c (patch)
treeba2413b432a83a0ad1151026840e746bf332df37 /src/gui/CMakeLists.txt
parentab01885e48873fb2ad71841a3f1627fe4d9cd835 (diff)
Move UNIX services into QtGui
Task-number: QTBUG-83255 Change-Id: I95cd25c6e18ffb46955acc76d6cab551d1c8f5ae Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io>
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index 205a2392d7..7a7989630e 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -859,6 +859,16 @@ qt_extend_target(Gui CONDITION QT_FEATURE_glib AND UNIX
GLIB2::GLIB2
)
+qt_extend_target(Gui CONDITION UNIX AND (QT_FEATURE_xcb OR NOT UIKIT)
+ SOURCES
+ platform/unix/qgenericunixservices.cpp platform/unix/qgenericunixservices_p.h
+)
+
+qt_extend_target(Gui CONDITION TARGET Qt::DBus AND UNIX AND (QT_FEATURE_xcb OR NOT UIKIT)
+ LIBRARIES
+ Qt::DBus
+)
+
qt_extend_target(Gui CONDITION IOS OR MACOS
SOURCES
rhi/qrhimetal.mm rhi/qrhimetal_p.h