summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2020-07-03 08:32:08 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2020-07-04 20:46:07 +0200
commit864466d2e5ae9ab7a2e01a7da3abc5a4c0b16bda (patch)
treef1c09a2320f2455d3f2c81a9e91031f4a8b9d849 /src/gui/CMakeLists.txt
parent90f1ef14aaf2f4b4dc49755ab8605e6a37ee06c6 (diff)
Move xkbcommon to QtGui
Task-number: QTBUG-83255 Change-Id: Ia1c6a49af6be4aaa6b988537c38db3a2c0a646a5 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io>
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index aff73daeee..db6f463c0b 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -898,6 +898,14 @@ qt_extend_target(Gui CONDITION QT_FEATURE_systemtrayicon AND TARGET Qt::DBus AND
platform/unix/dbustray/qxdgnotificationproxy.cpp platform/unix/dbustray/qxdgnotificationproxy_p.h
)
+qt_extend_target(Gui CONDITION QT_FEATURE_xkbcommon AND UNIX
+ SOURCES
+ platform/unix/qxkbcommon.cpp platform/unix/qxkbcommon_p.h
+ platform/unix/qxkbcommon_3rdparty.cpp
+ PUBLIC_LIBRARIES
+ XKB::XKB
+)
+
qt_extend_target(Gui CONDITION IOS OR MACOS
SOURCES
rhi/qrhimetal.mm rhi/qrhimetal_p.h