summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorAntti Määttä <antti.maatta@qt.io>2022-09-19 08:23:13 +0300
committerAntti Määttä <antti.maatta@qt.io>2023-01-13 12:43:44 +0200
commit9bdf74a4f23d009777f1cbdb0078aa70060a3da5 (patch)
tree19266522b16ee01f15bfcf3be58dbad515b62808 /src/gui/CMakeLists.txt
parentf488c657216115d33753429e8500b99b6e8e7c4c (diff)
Add tracepointgen tool and convert qtgui to use it
Allows automatically generating tracepoint files by scanning source files for instrumentation macros. This makes it easier to add tracepoint support to modules and also ensures that the tracepoint files do not get out of sync with the functions they are tracing. Q_TRACE_INSTRUMENT generates entry/exit tracespoints for a function it is set. Q_TRACE_PARAM_REPLACE is used to change a function parameter for these functions to convert it to supported parameter type. Q_TRACE_POINT can be used to create a standalone tracepoint. Q_TRACE_PREFIX can be used to add prefix for generated tracing backend for example to add includes for types used in the trace points.. Task-number: QTBUG-107238 Pick-to: 6.5 Change-Id: Ib395b80838434ceb72683dac0545ca20c4d09455 Reviewed-by: Tomi Korpipää <tomi.korpipaa@qt.io>
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index 354432195a..923d1628c1 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -973,8 +973,11 @@ qt_internal_extend_target(Gui CONDITION (QT_FEATURE_eglfs OR QT_FEATURE_xcb)
util/qedidvendortable_p.h
)
-
-qt_internal_create_tracepoints(Gui qtgui.tracepoints)
+qt_internal_generate_tracepoints(Gui gui
+ SOURCES
+ image/qimage.cpp image/qimagereader.cpp image/qpixmap.cpp kernel/qguiapplication.cpp
+ text/qfontdatabase.cpp
+)
qt_internal_add_docs(Gui
doc/qtgui.qdocconf
)