summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2022-12-08 11:29:17 +0100
committerAlexey Edelev <alexey.edelev@qt.io>2022-12-10 11:44:39 +0100
commita02750d12f84a5c7dcc72be6b71fac517b82ca09 (patch)
tree85a6aae392c17c138a9471217edcbaa41e596476 /src/gui/CMakeLists.txt
parentb9c80ecc08d98052e4757a916a8a55701be63497 (diff)
Isolate freetype feature
If freetype feature is not enabled we don't deliver its header files as part of Qt. The freetype font database was used as the generic fontdata base for unix platforms. This uses QPlatformFontDatabase as the generic one if neither fontconfig nor freetype features are enabled. Fixes: QTBUG-109270 Change-Id: I9e935fd1557db417eb94d44b6a0d88818d567fbe Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Eskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index b72e65dd28..a8e4d12718 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -748,7 +748,7 @@ qt_internal_extend_target(Gui CONDITION QT_FEATURE_freetype
WrapFreetype::WrapFreetype
)
-qt_internal_extend_target(Gui CONDITION QT_FEATURE_freetype AND UNIX AND NOT APPLE
+qt_internal_extend_target(Gui CONDITION UNIX AND NOT APPLE
SOURCES
text/unix/qgenericunixfontdatabase_p.h
)