summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2023-06-15 13:02:48 +0200
committerTor Arne Vestbø <tor.arne.vestbo@qt.io>2023-06-17 17:52:01 +0200
commita452e2254644ffbed289fdf051eaf41d7e6a3b0d (patch)
treeee95efa28444c7eb1ea891aeaae11237ee3d6c80 /src/gui/CMakeLists.txt
parent14f31bf16e9eb5c31a944711225af90f23123a5c (diff)
Unify QIcon theme icon loading and cache invalidation
The logic for invalidating a theme QIcon when the platform theme changed, or when the user set an explicit icon theme, was tied to QIconLoaderEngine, so any platform theme implementing QPlatformTheme::createIconEngine() with a custom icon engine would not take part in this cache invalidation. As we want users of QIcon::fromTheme to be agnostic to where the icon is actually coming from, and have a consistent behavior for the various QIcon APIs for setting explicit themes, the logic for invalidating the themed icon has now been moved up one layer, to a new QThemeIconEngine, that is responsible for lazily creating the actual engine based on the name. The engine proxies the actual icon loading through to the real engine via a new QProxyIconEngine helper class. Pick-to: 6.6 Change-Id: I474589981f751d7467e3073533cba542182f2d36 Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io> Reviewed-by: Axel Spoerl <axel.spoerl@qt.io>
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index 1b182d971d..37cefa9a25 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -62,7 +62,7 @@ qt_internal_add_module(Gui
image/qbitmap.cpp image/qbitmap.h
image/qbmphandler.cpp image/qbmphandler_p.h
image/qicon.cpp image/qicon.h image/qicon_p.h
- image/qiconengine.cpp image/qiconengine.h
+ image/qiconengine.cpp image/qiconengine.h image/qiconengine_p.h
image/qiconengineplugin.cpp image/qiconengineplugin.h
image/qiconloader.cpp image/qiconloader_p.h
image/qimage.cpp image/qimage.h image/qimage_p.h