summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorThiago Macieira <thiago.macieira@intel.com>2021-12-18 21:01:53 -0300
committerThiago Macieira <thiago.macieira@intel.com>2022-01-17 21:31:32 -0300
commitb6fb53a47ab20586efb7761513ab7af683495b67 (patch)
tree8be3f177a9eed995db4906143b9271b2eb1d1c40 /src/gui/CMakeLists.txt
parent037fd545c485e73ac68377a264c84208592dc74f (diff)
CMake: re-enable SIMD on Android
Except for MIPS, which is disabled in Qt 5 too. It's not my place to question why. This partially reverses commit b6e75ff3eaccc4f0322c9735533a1f3435597eba. Change-Id: Ib42b3adc93bf4d43bd55fffd16c1feffb9c5890c Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Assam Boudjelthia <assam.boudjelthia@qt.io>
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt68
1 files changed, 34 insertions, 34 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index ec72a598f1..19b6332820 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -564,38 +564,45 @@ qt_internal_extend_target(Gui CONDITION ((QT_FEATURE_png) AND (WIN32 AND MINGW))
-fno-reorder-blocks-and-partition
)
-if(NOT ANDROID)
- if(TEST_architecture_arch STREQUAL x86_64)
- qt_internal_extend_target(Gui
- SOURCES
- painting/qdrawhelper_sse2.cpp
- )
- else()
- qt_internal_add_simd_part(Gui SIMD sse2
- SOURCES
- painting/qdrawhelper_sse2.cpp
- )
- endif()
-
- qt_internal_add_simd_part(Gui SIMD ssse3
- SOURCES
- image/qimage_ssse3.cpp
- painting/qdrawhelper_ssse3.cpp
+if(TEST_architecture_arch STREQUAL x86_64)
+ qt_internal_extend_target(Gui
+ SOURCES
+ painting/qdrawhelper_sse2.cpp
)
-
- qt_internal_add_simd_part(Gui SIMD sse4_1
+else()
+ qt_internal_add_simd_part(Gui SIMD sse2
SOURCES
- painting/qdrawhelper_sse4.cpp
- painting/qimagescale_sse4.cpp
+ painting/qdrawhelper_sse2.cpp
)
+endif()
- qt_internal_add_simd_part(Gui SIMD neon
- SOURCES
- image/qimage_neon.cpp
- painting/qdrawhelper_neon.cpp painting/qdrawhelper_neon_p.h
- painting/qimagescale_neon.cpp
- )
+qt_internal_add_simd_part(Gui SIMD ssse3
+ SOURCES
+ image/qimage_ssse3.cpp
+ painting/qdrawhelper_ssse3.cpp
+)
+
+qt_internal_add_simd_part(Gui SIMD sse4_1
+ SOURCES
+ painting/qdrawhelper_sse4.cpp
+ painting/qimagescale_sse4.cpp
+)
+qt_internal_add_simd_part(Gui SIMD arch_haswell
+ SOURCES
+ painting/qdrawhelper_avx2.cpp
+ EXCLUDE_OSX_ARCHITECTURES
+ arm64
+)
+
+qt_internal_add_simd_part(Gui SIMD neon
+ SOURCES
+ image/qimage_neon.cpp
+ painting/qdrawhelper_neon.cpp painting/qdrawhelper_neon_p.h
+ painting/qimagescale_neon.cpp
+)
+
+if(NOT ANDROID)
qt_internal_add_simd_part(Gui SIMD mips_dsp
SOURCES
painting/qdrawhelper_mips_dsp.cpp painting/qdrawhelper_mips_dsp_p.h
@@ -609,13 +616,6 @@ if(NOT ANDROID)
image/qimage_mips_dspr2_asm.S
painting/qdrawhelper_mips_dspr2_asm.S
)
-
- qt_internal_add_simd_part(Gui SIMD arch_haswell
- SOURCES
- painting/qdrawhelper_avx2.cpp
- EXCLUDE_OSX_ARCHITECTURES
- arm64
- )
endif()
qt_internal_extend_target(Gui CONDITION ANDROID