summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorAxel Spoerl <axel.spoerl@qt.io>2022-09-16 16:14:49 +0200
committerAxel Spoerl <axel.spoerl@qt.io>2022-09-24 01:30:48 +0200
commitd35feca20c02539d04f10c23fc057454cb3fcc12 (patch)
treef6aaf331877207697be38f52c23c2f78e48f9e4b /src/gui/CMakeLists.txt
parentac2154c7e90d68e4477cb383d1090aaa1939efec (diff)
Propagate appearance property from QPlatformTheme to QStyleHints
Implement appearance property, getter and notifier in QStyleHints. Update appearance property in QStyleHints when handling theme change in QGuiApplicationPrivate. Task-number: QTBUG-106381 Change-Id: Idd67ca9df248ec9d9e67c0d48121e8eead11a9e2 Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index bbcacccac0..2a95babc04 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -132,7 +132,7 @@ qt_internal_add_module(Gui
kernel/qrasterwindow.cpp kernel/qrasterwindow.h
kernel/qscreen.cpp kernel/qscreen.h kernel/qscreen_p.h
kernel/qsessionmanager.cpp kernel/qsessionmanager.h kernel/qsessionmanager_p.h
- kernel/qstylehints.cpp kernel/qstylehints.h
+ kernel/qstylehints.cpp kernel/qstylehints.h kernel/qstylehints_p.h
kernel/qsurface.cpp kernel/qsurface.h
kernel/qsurfaceformat.cpp kernel/qsurfaceformat.h
kernel/qtestsupport_gui.cpp kernel/qtestsupport_gui.h