summaryrefslogtreecommitdiffstats
path: root/src/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorJeongBong Seo <jb.seo@lge.com>2015-04-30 15:04:57 +0900
committerDominik Holland <dominik.holland@qt.io>2020-06-08 09:34:02 +0200
commitea86f1931991fed9034e67399a2a88c7939eca6c (patch)
treeb77b139a513f5cb19b9c2e0ae7eb1a0b182f5039 /src/gui/CMakeLists.txt
parent3279c8e7d72c5eee379fa8e4a2789acfe40445c0 (diff)
Add the 'accessiblebridge' as a plugintype of gui module
This patch makes the 'accesiblebridge' plugin configurable. Change-Id: I99f01fcd434be25bbbe5460bbc8cc1d76aa744b9 Task-number: QTBUG-83126 Pick-to: 5.15 Reviewed-by: Jan Arve Sæther <jan-arve.saether@qt.io>
Diffstat (limited to 'src/gui/CMakeLists.txt')
-rw-r--r--src/gui/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
index 3c844c7f51..246e8aef2c 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -53,17 +53,17 @@ endif()
qt_add_module(Gui
GENERATE_METATYPES
- PLUGIN_TYPES platforms platforms/darwin xcbglintegrations platformthemes platforminputcontexts generic iconengines imageformats egldeviceintegrations
+ PLUGIN_TYPES accessiblebridge platforms platforms/darwin xcbglintegrations platformthemes platforminputcontexts generic iconengines imageformats egldeviceintegrations
FEATURE_DEPENDENCIES # special case:
Qt::Network # special case:
QMAKE_MODULE_CONFIG "${qmake_module_config}" # special case
SOURCES
+ image/qabstractfileiconengine.cpp image/qabstractfileiconengine_p.h
image/qbitmap.cpp image/qbitmap.h
image/qbmphandler.cpp image/qbmphandler_p.h
image/qicon.cpp image/qicon.h image/qicon_p.h
image/qiconengine.cpp image/qiconengine.h
image/qiconengineplugin.cpp image/qiconengineplugin.h
- image/qabstractfileiconengine.cpp image/qabstractfileiconengine_p.h
image/qiconloader.cpp image/qiconloader_p.h
image/qimage.cpp image/qimage.h image/qimage_p.h
image/qimage_conversions.cpp