summaryrefslogtreecommitdiffstats
path: root/src/network/CMakeLists.txt
diff options
context:
space:
mode:
authorMårten Nordheim <marten.nordheim@qt.io>2023-07-05 16:38:32 +0200
committerMårten Nordheim <marten.nordheim@qt.io>2024-01-17 16:05:25 +0100
commit0dba3f6b713a657eb3bf2037face72d16253eb92 (patch)
treea980ea16b2954b6a2b149f96dc08ed7b8ef77582 /src/network/CMakeLists.txt
parent0534a93ef04f38cf6dfc0d6c03827325d651a64c (diff)
Privately introduce QHttp2Connection
For use in QtGRPC. There is some duplication between this code and the code in QHttp2ProtocolHandler. But let's not change the implementation of the protocol handler after the 6.7 beta release. Nor do I think we should do it for 6.8 LTS. So let's just live with the duplication until that has branched. Pick-to: 6.7 Fixes: QTBUG-105491 Change-Id: I69aa38a3c341347e702f9c07c27287aee38a16f2 Reviewed-by: Alexey Edelev <alexey.edelev@qt.io>
Diffstat (limited to 'src/network/CMakeLists.txt')
-rw-r--r--src/network/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/network/CMakeLists.txt b/src/network/CMakeLists.txt
index 4ef2699ee8..c4e0324deb 100644
--- a/src/network/CMakeLists.txt
+++ b/src/network/CMakeLists.txt
@@ -122,6 +122,7 @@ qt_internal_extend_target(Network CONDITION QT_FEATURE_http
access/qdecompresshelper.cpp access/qdecompresshelper_p.h
access/qhttp1configuration.cpp access/qhttp1configuration.h
access/qhttp2configuration.cpp access/qhttp2configuration.h
+ access/qhttp2connection.cpp access/qhttp2connection_p.h
access/qhttp2protocolhandler.cpp access/qhttp2protocolhandler_p.h
access/qhttpheaders.cpp access/qhttpheaders.h
access/qhttpmultipart.cpp access/qhttpmultipart.h access/qhttpmultipart_p.h