summaryrefslogtreecommitdiffstats
path: root/src/network/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2023-01-27 19:20:14 +0100
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2023-01-31 20:32:33 +0100
commit0fc1f8174f3a899d3c3ee969596a0ad260a7bb8e (patch)
tree962e9bda6ea2c95fed72007e5be57b5b0ba7917b /src/network/CMakeLists.txt
parent25c1eaa9b11653e5b03319fc58529c5107f98813 (diff)
QtNetwork/Windows: Add exclusions for CMake Unity (Jumbo) builds
The "interface" define in windows.h causes clashes with variables named "interface". It cannot be undef'ed since the winsock headers also uses it. Pick-to: 6.5 Task-number: QTBUG-109394 Change-Id: Id2daedfd6c57aae39a1fdfe92482f17884b68ef5 Reviewed-by: Timur Pocheptsov <timur.pocheptsov@qt.io> Reviewed-by: MÃ¥rten Nordheim <marten.nordheim@qt.io>
Diffstat (limited to 'src/network/CMakeLists.txt')
-rw-r--r--src/network/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/network/CMakeLists.txt b/src/network/CMakeLists.txt
index 61dc7784af..af8fa2b443 100644
--- a/src/network/CMakeLists.txt
+++ b/src/network/CMakeLists.txt
@@ -379,6 +379,25 @@ qt_internal_extend_target(Network CONDITION QNX PUBLIC_LIBRARIES socket) # speci
qt_internal_extend_target(Network CONDITION SOLARIS PUBLIC_LIBRARIES socket nsl) # special case
+if (WIN32)
+ set_source_files_properties(Network # include windows.h (causing clashes with "interface" define)
+ kernel/qauthenticator.cpp
+ kernel/qdnslookup_win.cpp
+ kernel/qhostaddress.cpp
+ kernel/qhostinfo.cpp
+ kernel/qhostinfo_win.cpp
+ kernel/qnetconmonitor_win.cpp
+ kernel/qnetworkinterface_win.cpp
+ kernel/qnetworkproxy_win.cpp
+ socket/qabstractsocket.cpp
+ socket/qlocalserver.cpp
+ socket/qlocalserver_win.cpp
+ socket/qlocalsocket_win.cpp
+ socket/qnativesocketengine.cpp
+ socket/qnativesocketengine_win.cpp
+ PROPERTIES SKIP_UNITY_BUILD_INCLUSION ON)
+endif()
+
# include the snippet projects for developer-builds
if(QT_FEATURE_private_tests)
add_subdirectory(doc/snippets/network)