summaryrefslogtreecommitdiffstats
path: root/src/network/CMakeLists.txt
diff options
context:
space:
mode:
authorThiago Macieira <thiago.macieira@intel.com>2023-12-03 13:07:44 -0800
committerThiago Macieira <thiago.macieira@intel.com>2023-12-07 14:55:06 -0800
commit93233516957f71054c42ba843cdd57216834acd7 (patch)
treed966ab3c5946b7dc7dae8c42f182e51915454a3e /src/network/CMakeLists.txt
parent40592d38f86129de7efc22b80ec832aaa6fa6b6b (diff)
Re-do the namespace fix for the linker scripts
This amends and corrects b63045477ea05c17f9abe9434e6d824453e3935a. The fix there was incorrect for two reasons: 1) it missed one symbol in QtCore (the QFutureInterfaceBase one added in 0f0371c8304bd7354a3c43f9fac6b85bd3e9a3f1. 2) it only worked for namespaces that were 15 characters long Instead, just use a wildcard where the namespace should be for Qt symbols (note: an extra wildcard appears for plain types because they go from <N><type> to N<N><namespace><N><type>E). Pick-to: 6.6 Change-Id: Iae41eb8991e349ceb836fffd179d6e709d6632f8 Reviewed-by: Alexey Edelev <alexey.edelev@qt.io> Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Michal Klocek <michal.klocek@qt.io>
Diffstat (limited to 'src/network/CMakeLists.txt')
-rw-r--r--src/network/CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/src/network/CMakeLists.txt b/src/network/CMakeLists.txt
index 9a616e0c34..502ba16987 100644
--- a/src/network/CMakeLists.txt
+++ b/src/network/CMakeLists.txt
@@ -400,15 +400,10 @@ qt_internal_extend_target(Network CONDITION WIN32
if(QT_FEATURE_private_tests)
add_subdirectory(doc/snippets/network)
endif()
-if (QT_NAMESPACE STREQUAL "")
- set(linker_script_symbol "_ZN16QNetworkDatagram7destroyEP23QNetworkDatagramPrivate")
-else()
- set(linker_script_symbol "_ZN15${QT_NAMESPACE}16QNetworkDatagram7destroyEPNS_23QNetworkDatagramPrivateE")
-endif()
qt_internal_extend_target(Network
# Workaround for QTBUG-118229:
# Function called by inline methods taking a pointer to a private class as a parameter
EXTRA_LINKER_SCRIPT_EXPORTS
# QNetworkDatagram::destroy(QNetworkDatagramPrivate *d)
- ${linker_script_symbol}
+ "_ZN*16QNetworkDatagram7destroyEP*23QNetworkDatagramPrivate*"
)