summaryrefslogtreecommitdiffstats
path: root/src/network/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2020-03-06 09:20:41 +0100
committerLeander Beernaert <leander.beernaert@qt.io>2020-03-06 12:32:58 +0100
commitb4f19e427775311c769f3a29864f9ad72ee2d791 (patch)
treea69a89ff8dfe1a2269d3679955259a8e9fd2cbd8 /src/network/CMakeLists.txt
parent8ffb9053ad300b1fc00b2dd4e808c99d03a3d7a4 (diff)
CMake: Remove special case handling for OpenSSL
Now that we can generate the library config tests which verify the OpenSSL version, we no longer need these special cases. Change-Id: I8ddccf4ae1c698db9fac391976b3b4b670712582 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/network/CMakeLists.txt')
-rw-r--r--src/network/CMakeLists.txt13
1 files changed, 0 insertions, 13 deletions
diff --git a/src/network/CMakeLists.txt b/src/network/CMakeLists.txt
index c455a00121..baea85ea99 100644
--- a/src/network/CMakeLists.txt
+++ b/src/network/CMakeLists.txt
@@ -1,18 +1,5 @@
# Generated from network.pro.
-# special case begin
-# Temporary fix for OpenSSL feature detection until we can provide a
-# proper implementation of additional compile tests for library dependencies
-# in configure.json
-
-find_package(OpenSSL)
-if (NOT OPENSSL_FOUND OR NOT OPENSSL_VERSION VERSION_GREATER_EQUAL "1.1.0")
- set(QT_FEATURE_openssl_runtime OFF CACHE BOOL "" FORCE)
- set(QT_FEATURE_openssl_linked OFF CACHE BOOL "" FORCE)
- set(QT_FEATURE_openssl OFF CACHE BOOL "" FORCE)
-endif()
-# special case end
-
#####################################################################
## Network Module:
#####################################################################