summaryrefslogtreecommitdiffstats
path: root/src/network/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-10-07 15:33:15 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-10-07 22:45:29 +0000
commitbdb8a5f6640b81a2461b34c1d6bd4b7b9281544f (patch)
tree0a883a09bdac0ea087f084350c38021022b0f4c4 /src/network/CMakeLists.txt
parent2c4a4ca5d1237983a1e8cc2d289116ebe389ee22 (diff)
Regenerate gui and network to handle source subtractions using script
Change-Id: Ifd7014b90e3eb054079de8904d9812cfd28b664d Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> Reviewed-by: Qt CMake Build Bot
Diffstat (limited to 'src/network/CMakeLists.txt')
-rw-r--r--src/network/CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/src/network/CMakeLists.txt b/src/network/CMakeLists.txt
index 427e7d877b..f2be442df2 100644
--- a/src/network/CMakeLists.txt
+++ b/src/network/CMakeLists.txt
@@ -157,11 +157,6 @@ extend_target(Network CONDITION UNIX
socket/qnet_unix_p.h
)
-extend_target(Network CONDITION QT_FEATURE_dnslookup AND UNIX AND NOT INTEGRITY AND NOT ANDROID
- SOURCES
- kernel/qdnslookup_unix.cpp
-)
-
extend_target(Network CONDITION QT_FEATURE_dlopen AND UNIX
LIBRARIES
${CMAKE_DL_LIBS}
@@ -443,9 +438,13 @@ extend_target(Network CONDITION QT_FEATURE_openssl AND QT_FEATURE_ssl AND WIN32
crypt32
)
-extend_target(Network CONDITION WIN32 PUBLIC_LIBRARIES ws2_32) # special case: mkspecs/common/msvc-desktop.conf
+extend_target(Network CONDITION QT_FEATURE_dnslookup AND UNIX AND NOT ANDROID AND NOT INTEGRITY
+ SOURCES
+ kernel/qdnslookup_unix.cpp
+)
add_qt_docs(Network
doc/qtnetwork.qdocconf
)
+extend_target(Network CONDITION WIN32 PUBLIC_LIBRARIES ws2_32) # special case: mkspecs/common/msvc-desktop.conf