summaryrefslogtreecommitdiffstats
path: root/src/network/CMakeLists.txt
diff options
context:
space:
mode:
authorMårten Nordheim <marten.nordheim@qt.io>2020-05-06 18:30:43 +0200
committerMårten Nordheim <marten.nordheim@qt.io>2020-08-14 13:17:11 +0200
commitd40f88e8d23f9d5fdb08ff9a394d9697a0d86fc8 (patch)
tree73384e08f6d362bfc7f1da9f5ce2ff0b28641c4e /src/network/CMakeLists.txt
parent94b7a4f9b8d0746dae54b0a1870f119e8b17830d (diff)
QDecompressHelper: Introduce zstd support
Also take this opportunity to reshuffle the content-encodings in the intended ordering since the ordering is used to signify priority. Task-number: QTBUG-83269 Change-Id: I022eecf1ba03b54dbd9c98a9d63d05fb05fd2124 Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
Diffstat (limited to 'src/network/CMakeLists.txt')
-rw-r--r--src/network/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/network/CMakeLists.txt b/src/network/CMakeLists.txt
index 157a31f1da..309122fa73 100644
--- a/src/network/CMakeLists.txt
+++ b/src/network/CMakeLists.txt
@@ -128,6 +128,11 @@ qt_extend_target(Network CONDITION QT_FEATURE_brotli AND QT_FEATURE_http
WrapBrotli::WrapBrotliDec
)
+qt_extend_target(Network CONDITION QT_FEATURE_http AND QT_FEATURE_zstd
+ LIBRARIES
+ ZSTD::ZSTD
+)
+
qt_extend_target(Network CONDITION QT_FEATURE_system_zlib
LIBRARIES
ZLIB::ZLIB