summaryrefslogtreecommitdiffstats
path: root/src/network/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2023-02-01 11:28:29 +0100
committerTor Arne Vestbø <tor.arne.vestbo@qt.io>2023-02-01 20:25:08 +0100
commitffd6a4264b43b651cf8038b94b849086645ed8c2 (patch)
tree36238e3d08c16c269ec9b61e5257557d6b23397e /src/network/CMakeLists.txt
parentbd5589de658a91676b0cf36e154c19985fb7be88 (diff)
Don't include qnetworkproxy_generic.cpp for iOS
We already have the necessary machinery in qnetworkproxy_darwin.cpp Pick-to: 6.5 Change-Id: I01d99c825ed794f1ff5ba229e64f9963b819228c Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/network/CMakeLists.txt')
-rw-r--r--src/network/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/network/CMakeLists.txt b/src/network/CMakeLists.txt
index af8fa2b443..24a57a8635 100644
--- a/src/network/CMakeLists.txt
+++ b/src/network/CMakeLists.txt
@@ -283,7 +283,7 @@ qt_internal_extend_target(Network CONDITION ANDROID # special case
kernel/qnetworkproxy_android.cpp
)
-qt_internal_extend_target(Network CONDITION UNIX AND NOT ANDROID AND NOT MACOS AND NOT QT_FEATURE_libproxy AND (UNIX OR WINRT) # special case
+qt_internal_extend_target(Network CONDITION UNIX AND NOT ANDROID AND NOT APPLE AND NOT QT_FEATURE_libproxy AND (UNIX OR WINRT) # special case
SOURCES
kernel/qnetworkproxy_generic.cpp
)