summaryrefslogtreecommitdiffstats
path: root/src/opengl/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-01-22 10:00:34 +0100
committerTobias Hunger <tobias.hunger@qt.io>2019-01-25 14:33:26 +0000
commite2ff9e3b9957f844d6530cc92096bed3c16fa46a (patch)
tree1abe90bac9e6d0d01c205ea4f55f6463b35109fc /src/opengl/CMakeLists.txt
parent0690c145db99da66dd3e2dc936848862661a161b (diff)
CMake: Introduce Q_OBJECT qdoc macro
CMake's moc file scanning is rather primitive: It will run moc on any file containing a line that starts with Q_OBJECT (and similar macros). We have four files in QtBase that contain such a macro at the start of the line in a qdoc comment. These four files were excluded from automatic moc handling by cmake, which is not ideal, since this will silently fail when somebody actually adds a Q_OBJECT macro in code. This patch introduces a macro Q_OBJECT for qdoc. This macro will be replaced with Q_OBJECT in the generated documentation. While not nice, at least a failure to use \Q_OBJECT is noticeable: Moc will warn about the file. Change-Id: I829893c1166eee306fe30058d4ea0256affd45ea Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> Reviewed-by: Paul Wicking <paul.wicking@qt.io>
Diffstat (limited to 'src/opengl/CMakeLists.txt')
-rw-r--r--src/opengl/CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/src/opengl/CMakeLists.txt b/src/opengl/CMakeLists.txt
index 14750f3a3f..f67fea4d16 100644
--- a/src/opengl/CMakeLists.txt
+++ b/src/opengl/CMakeLists.txt
@@ -31,12 +31,6 @@ add_qt_module(OpenGL
Qt::GuiPrivate
Qt::WidgetsPrivate
)
-set_source_files_properties(qglfunctions.cpp qgraphicsshadereffect.cpp PROPERTIES
- SKIP_AUTOMOC ON
- SKIP_AUTOUIC ON
- SKIP_AUTORCC ON
-)
-
## Scopes:
#####################################################################