summaryrefslogtreecommitdiffstats
path: root/src/platformsupport/CMakeLists.txt
diff options
context:
space:
mode:
authorAlbert Astals Cid <albert.astals.cid@kdab.com>2019-01-31 11:43:51 +0100
committerTobias Hunger <tobias.hunger@qt.io>2019-02-01 12:27:11 +0000
commit70419e31f9a8de172459a6e1cce67e816c7ddbed (patch)
treedddcc8a7c88398d0c81e4e52f622941ee73a3070 /src/platformsupport/CMakeLists.txt
parentb6306cb06675cdab2c1a6d68dcad5201bae5db87 (diff)
cmake: Fix build of xcb platform plugin when vulkan is available
Change-Id: I79760aa0cb08752cfc20aabc1a890f60c91c9dfd Reviewed-by: Tobias Hunger <tobias.hunger@qt.io>
Diffstat (limited to 'src/platformsupport/CMakeLists.txt')
-rw-r--r--src/platformsupport/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/platformsupport/CMakeLists.txt b/src/platformsupport/CMakeLists.txt
index e298eb4bc5..a86b958c10 100644
--- a/src/platformsupport/CMakeLists.txt
+++ b/src/platformsupport/CMakeLists.txt
@@ -19,6 +19,10 @@ if(QT_FEATURE_accessibility)
endif()
endif()
+if(QT_FEATURE_vulkan)
+ add_subdirectory(vkconvenience)
+endif()
+
if(APPLE)
add_subdirectory(clipboard)
add_subdirectory(graphics)