summaryrefslogtreecommitdiffstats
path: root/src/platformsupport/CMakeLists.txt
diff options
context:
space:
mode:
authorAlbert Astals Cid <albert.astals.cid@kdab.com>2019-02-11 14:23:40 +0100
committerAlbert Astals Cid <albert.astals.cid@kdab.com>2019-02-11 14:02:12 +0000
commit8ee0cb04bd2c455151dd34b02d1d8a830021efd1 (patch)
treed71bd6cec8854b642143a8ffa601b51fe522aaa2 /src/platformsupport/CMakeLists.txt
parentbeace29a573df43b242d611f94bbd23af4232797 (diff)
cmake: build glxconvenience
Change-Id: Iad09a86d11565665bb06d8d5d5616fc1b35ad777 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/platformsupport/CMakeLists.txt')
-rw-r--r--src/platformsupport/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/platformsupport/CMakeLists.txt b/src/platformsupport/CMakeLists.txt
index b4b5c8a8dc..826cda3903 100644
--- a/src/platformsupport/CMakeLists.txt
+++ b/src/platformsupport/CMakeLists.txt
@@ -41,6 +41,10 @@ if(QT_FEATURE_opengl)
add_subdirectory(platformcompositor)
endif()
+if (QT_FEATURE_xlib AND QT_FEATURE_opengl AND (NOT QT_FEATURE_opengles2))
+ add_subdirectory(glxconvenience)
+endif()
+
if(APPLE)
add_subdirectory(clipboard)
add_subdirectory(graphics)