summaryrefslogtreecommitdiffstats
path: root/src/platformsupport/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-03-07 19:54:52 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-03-18 15:35:07 +0000
commita9af99c926a4f7da597a965923328cfdc112004a (patch)
treedaaa7500eb4831f7641cbd9e0c19eb4ca5958094 /src/platformsupport/CMakeLists.txt
parent3f03917b54ace1041f7a640dc65b452b0275fafc (diff)
Add windows platform plugin and its requirements
- executed pro2cmake script on windows qpa plugin - added windowsuiautomation platformsupport project - fixed plugin dlls and lib files to be written to the same path - fixed an issue comErrorString which used implicit casting from QString to char*, but plugins are currently built with QT_NO_CAST_TO_ASCII Task-number: QTBUG-74140 Change-Id: I5db3b6c5264bbd5dfba2998b049fda36eb312c70 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/platformsupport/CMakeLists.txt')
-rw-r--r--src/platformsupport/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/platformsupport/CMakeLists.txt b/src/platformsupport/CMakeLists.txt
index 826cda3903..ece4eed2aa 100644
--- a/src/platformsupport/CMakeLists.txt
+++ b/src/platformsupport/CMakeLists.txt
@@ -23,6 +23,9 @@ if(QT_FEATURE_accessibility)
if(QT_FEATURE_accessibility_atspi_bridge)
add_subdirectory(linuxaccessibility)
endif()
+ if(WIN32 AND NOT WINRT)
+ add_subdirectory(windowsuiautomation)
+ endif()
endif()
if(QT_FEATURE_vulkan)