summaryrefslogtreecommitdiffstats
path: root/src/platformsupport/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Hausmann <simon.hausmann@qt.io>2018-10-24 15:20:27 +0200
committerTobias Hunger <tobias.hunger@qt.io>2018-11-01 11:48:46 +0000
commite9c45bbdddd4df005bdaa5eea9740d351e6eaea2 (patch)
tree23765d4650f8f349d1f32e0fe4b1bc678cae7568 /src/platformsupport/CMakeLists.txt
parent345e6b0213b1273b698163064f80d33bc7ce64a9 (diff)
Begin port of qtbase to CMake
Done-by: Alexandru Croitor <alexandru.croitor@qt.io> Done-by: Frederik Gladhorn <frederik.gladhorn@qt.io> Done-by: Kevin Funk <kevin.funk@kdab.com> Done-by: Mikhail Svetkin <mikhail.svetkin@qt.io> Done-by: Simon Hausmann <simon.hausmann@qt.io> Done-by: Tobias Hunger <tobias.hunger@qt.io> Done-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io> Done-by: Volker Krause <volker.krause@kdab.com> Change-Id: Ida4f8bd190f9a4849a1af7b5b7981337a5df5310 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> Reviewed-by: Tobias Hunger <tobias.hunger@qt.io> Reviewed-by: Mikhail Svetkin <mikhail.svetkin@qt.io>
Diffstat (limited to 'src/platformsupport/CMakeLists.txt')
-rw-r--r--src/platformsupport/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/platformsupport/CMakeLists.txt b/src/platformsupport/CMakeLists.txt
new file mode 100644
index 0000000000..158cecbec0
--- /dev/null
+++ b/src/platformsupport/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Generated from platformsupport.pro.
+
+qt_pull_features_into_current_scope(PRIVATE_FEATURES Qt::Gui)
+add_subdirectory(themes)
+add_subdirectory(edid)
+add_subdirectory(eventdispatchers)
+
+if(QT_FEATURE_freetype OR APPLE OR WIN32)
+ add_subdirectory(fontdatabases)
+endif()
+
+if((UNIX AND (NOT uikit)) OR QT_FEATURE_xcb)
+ add_subdirectory(services)
+endif()
+
+if(QT_FEATURE_accessibility)
+ add_subdirectory(accessibility)
+endif()
+
+if(APPLE)
+ add_subdirectory(clipboard)
+ add_subdirectory(graphics)
+endif()