summaryrefslogtreecommitdiffstats
path: root/src/platformsupport/fontdatabases/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2020-06-12 07:38:54 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2020-06-15 11:34:26 +0200
commit6be9830d865be32f224e15d13ddefd9c7e176553 (patch)
tree8938ff202f53f3ad0f4e8facee84f0acdf9af093 /src/platformsupport/fontdatabases/CMakeLists.txt
parent927a82f5e0d0e8a174cbb027c58412e13f7067c5 (diff)
Move Unix font databases into QtGui
Task-number: QTBUG-83255 Change-Id: Id85a1e0f3de371951783fe97485158c4a02e1f15 Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io>
Diffstat (limited to 'src/platformsupport/fontdatabases/CMakeLists.txt')
-rw-r--r--src/platformsupport/fontdatabases/CMakeLists.txt48
1 files changed, 0 insertions, 48 deletions
diff --git a/src/platformsupport/fontdatabases/CMakeLists.txt b/src/platformsupport/fontdatabases/CMakeLists.txt
deleted file mode 100644
index 2f4519ec30..0000000000
--- a/src/platformsupport/fontdatabases/CMakeLists.txt
+++ /dev/null
@@ -1,48 +0,0 @@
-# Generated from fontdatabases.pro.
-
-qt_find_package(WrapFreetype PROVIDED_TARGETS WrapFreetype::WrapFreetype) # special case
-qt_find_package(Fontconfig) # special case
-
-#####################################################################
-## FontDatabaseSupport Module:
-#####################################################################
-
-qt_add_module(FontDatabaseSupport
- STATIC
- INTERNAL_MODULE
- DEFINES
- QT_NO_CAST_FROM_ASCII
- PUBLIC_LIBRARIES
- Qt::CorePrivate
- Qt::GuiPrivate
- PRECOMPILED_HEADER
- "../../corelib/global/qt_pch.h"
-)
-
-#### Keys ignored in scope 1:.:.:fontdatabases.pro:<TRUE>:
-# MODULE = "fontdatabase_support"
-
-## Scopes:
-#####################################################################
-
-qt_extend_target(FontDatabaseSupport CONDITION UNIX
- SOURCES
- genericunix/qgenericunixfontdatabase_p.h
-)
-
-qt_extend_target(FontDatabaseSupport CONDITION QT_FEATURE_fontconfig
- SOURCES
- fontconfig/qfontconfigdatabase.cpp fontconfig/qfontconfigdatabase_p.h
- fontconfig/qfontenginemultifontconfig.cpp fontconfig/qfontenginemultifontconfig_p.h
- LIBRARIES
- Fontconfig::Fontconfig
-)
-
-# special case begin
-if(TARGET WrapFreetype::WrapFreetype)
- qt_extend_target(FontDatabaseSupport CONDITION QT_FEATURE_fontconfig
- LIBRARIES
- WrapFreetype::WrapFreetype
-)
-endif()
-# special case end