summaryrefslogtreecommitdiffstats
path: root/src/platformsupport/fontdatabases/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-04-02 14:13:27 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-04-02 13:32:21 +0000
commite2e4525f7841d95c531218297ef0d57b6280aa3d (patch)
treef9322778429bd79fa983082a591f8960f02c0174 /src/platformsupport/fontdatabases/CMakeLists.txt
parent72e0f74e31a7d293a8c4f440a564efe6d1352cb7 (diff)
Fix simplification of conditions involving apple
Previously a condition like APPLE AND (NOT APPLE_OSX) got simplified to APPLE, which is wrong. This happened by accident due to some sub-family simplifications involving BSD, which APPLE was part of. Technically APPLE is BSD derived, but for the purposes of the conversion script consider APPLE not to be a BSD (hopefully there should be no cases of using the bsd scope for apple machines in qmake files. Also regenerate the fontdatabase project, where the issue was found. Change-Id: I18dcf4f29ffbff48c183ba95ca2a2e5cd5325d86 Reviewed-by: Tobias Hunger <tobias.hunger@qt.io>
Diffstat (limited to 'src/platformsupport/fontdatabases/CMakeLists.txt')
-rw-r--r--src/platformsupport/fontdatabases/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/platformsupport/fontdatabases/CMakeLists.txt b/src/platformsupport/fontdatabases/CMakeLists.txt
index 9622000ab5..be1047eb13 100644
--- a/src/platformsupport/fontdatabases/CMakeLists.txt
+++ b/src/platformsupport/fontdatabases/CMakeLists.txt
@@ -32,7 +32,6 @@ extend_target(FontDatabaseSupport CONDITION APPLE
${FWCoreGraphics}
${FWCoreText}
${FWFoundation}
- ${FWUIKit}
)
#### Keys ignored in scope 2:.:fontdatabases.pro:APPLE:
@@ -50,6 +49,11 @@ extend_target(FontDatabaseSupport CONDITION APPLE_OSX
${FWAppKit}
)
+extend_target(FontDatabaseSupport CONDITION APPLE AND NOT APPLE_OSX
+ LIBRARIES
+ ${FWUIKit}
+)
+
extend_target(FontDatabaseSupport CONDITION QT_FEATURE_freetype
SOURCES
freetype/qfontengine_ft.cpp freetype/qfontengine_ft_p.h