summaryrefslogtreecommitdiffstats
path: root/src/plugins/imageformats/CMakeLists.txt
diff options
context:
space:
mode:
authorAlbert Astals Cid <albert.astals.cid@kdab.com>2019-01-31 17:36:49 +0100
committerTobias Hunger <tobias.hunger@qt.io>2019-02-01 12:27:27 +0000
commit6d51f69bbf3d88f7da46586a01c26034850ce897 (patch)
tree319de483526712c1cf2a54cb595a38bba2fc4788 /src/plugins/imageformats/CMakeLists.txt
parent70419e31f9a8de172459a6e1cce67e816c7ddbed (diff)
cmake: Build src/plugins/imageformats
Change-Id: I4bf09c50eebf71255590e9b17e637ce621d3cd40 Reviewed-by: Frederik Gladhorn <frederik.gladhorn@qt.io> Reviewed-by: Tobias Hunger <tobias.hunger@qt.io>
Diffstat (limited to 'src/plugins/imageformats/CMakeLists.txt')
-rw-r--r--src/plugins/imageformats/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/plugins/imageformats/CMakeLists.txt b/src/plugins/imageformats/CMakeLists.txt
new file mode 100644
index 0000000000..cd5c0347e5
--- /dev/null
+++ b/src/plugins/imageformats/CMakeLists.txt
@@ -0,0 +1,11 @@
+if(QT_FEATURE_gif)
+ add_subdirectory(gif)
+endif()
+if(QT_FEATURE_ico)
+ add_subdirectory(ico)
+endif()
+if(QT_FEATURE_jpeg)
+ add_subdirectory(jpeg)
+endif()
+
+