summaryrefslogtreecommitdiffstats
path: root/src/plugins/imageformats/ico/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-05-06 15:28:53 +0200
committerTobias Hunger <tobias.hunger@qt.io>2019-05-06 14:46:16 +0000
commitb65e7b2ffee52b7a9f6df829c7925fa54b4d7ad8 (patch)
tree6834f6a699791abbd779ef95db56b0f0d58e6f51 /src/plugins/imageformats/ico/CMakeLists.txt
parent0434b7fb38c33b26700daabe31a29ab0cd4294d7 (diff)
CMake: Regenerate src/plugins/imageformats
Change-Id: Iea0f1b5f51508b7e8c2cad405dd3e293186c583a Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/plugins/imageformats/ico/CMakeLists.txt')
-rw-r--r--src/plugins/imageformats/ico/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/plugins/imageformats/ico/CMakeLists.txt b/src/plugins/imageformats/ico/CMakeLists.txt
index 52550eab60..160b440dff 100644
--- a/src/plugins/imageformats/ico/CMakeLists.txt
+++ b/src/plugins/imageformats/ico/CMakeLists.txt
@@ -10,6 +10,12 @@ add_qt_plugin(qico
main.cpp main.h
qicohandler.cpp qicohandler.h
LIBRARIES
- Qt::Gui
- Qt::CorePrivate
+ Qt::GuiPrivate # special case
+ PUBLIC_LIBRARIES # special case
+ Qt::Gui # special case
)
+
+#### Keys ignored in scope 1:.:.:ico.pro:<TRUE>:
+# OTHER_FILES = "ico.json"
+# PLUGIN_CLASS_NAME = "QICOPlugin"
+# _LOADED = "qt_plugin"