summaryrefslogtreecommitdiffstats
path: root/src/plugins/networkinformationbackends/scnetworkreachability/CMakeLists.txt
diff options
context:
space:
mode:
authorMÃ¥rten Nordheim <marten.nordheim@qt.io>2021-01-28 09:56:23 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-02-06 10:28:14 +0000
commitb063d22147c9945e0686d43e0b00a062677d11c3 (patch)
treef0e930cbffa425f15a5da031597e187564f6927a /src/plugins/networkinformationbackends/scnetworkreachability/CMakeLists.txt
parentd6f00c637d6e12986a42e3c00622e7801b55a5d0 (diff)
SCNetworkReachability based backend for QNetworkInformation
For macOS/iOS. Based on the code Timur wrote for QNetworkStatusMonitor, and uses QNetworkConnectionMonitor. It has less detail than the other backends which is unfortunate but should be fine! Task-number: QTBUG-86966 Change-Id: I0d5930d539f9668f001d6f85c86c9df0803d0f60 Reviewed-by: Timur Pocheptsov <timur.pocheptsov@qt.io> (cherry picked from commit 309a2360fdb3e9c1b07d2937859c521da187c486) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'src/plugins/networkinformationbackends/scnetworkreachability/CMakeLists.txt')
-rw-r--r--src/plugins/networkinformationbackends/scnetworkreachability/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/plugins/networkinformationbackends/scnetworkreachability/CMakeLists.txt b/src/plugins/networkinformationbackends/scnetworkreachability/CMakeLists.txt
new file mode 100644
index 0000000000..d4a1c52c3f
--- /dev/null
+++ b/src/plugins/networkinformationbackends/scnetworkreachability/CMakeLists.txt
@@ -0,0 +1,10 @@
+qt_internal_add_plugin(QSCNetworkReachabilityNetworkInformationBackend
+ OUTPUT_NAME scnetworkreachabilitynetworkinformationbackend
+ TYPE networkinformationbackends
+ DEFAULT_IF APPLE
+ SOURCES
+ qscnetworkreachabilitynetworkinformationbackend.mm
+ PUBLIC_LIBRARIES
+ Qt::NetworkPrivate
+ ${FWSystemConfiguration}
+)