summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/android/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-10-11 16:55:55 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-10-14 19:01:19 +0000
commit190e9dcdcf1a2debfbf624af4cb2154172908a64 (patch)
tree3feb15de63b05cda8339d784c46f929ad4000357 /src/plugins/platforms/android/CMakeLists.txt
parent440286655e0ca271506cf7cc02ad0dbf4baef9ca (diff)
Regenerate files after dev -> wip/cmake merge
Note the following bigger things that had to be done: Handle GSS library / feature with a new custom find module. Implement rudimentary support for relocatability (does not currently handle extprefix). Change-Id: Ic6cd27dda7ebca9829f51cb42ea76fff6d1767ef Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/plugins/platforms/android/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/android/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/plugins/platforms/android/CMakeLists.txt b/src/plugins/platforms/android/CMakeLists.txt
index f8d23e8371..331ec21fe5 100644
--- a/src/plugins/platforms/android/CMakeLists.txt
+++ b/src/plugins/platforms/android/CMakeLists.txt
@@ -6,7 +6,7 @@
add_qt_plugin(qtforandroid
TYPE platforms
- # OUTPUT_DIRECTORY "$$DESTDIR/android" # special case remove
+ CLASS_NAME QAndroidIntegrationPlugin
DEFAULT_IF ${QT_QPA_DEFAULT_PLATFORM} MATCHES android # special case
SOURCES
androidcontentfileengine.cpp androidcontentfileengine.h
@@ -18,6 +18,7 @@ add_qt_plugin(qtforandroid
androidjnimenu.cpp androidjnimenu.h
androidplatformplugin.cpp
androidsurfaceclient.h
+ main.cpp
qandroidassetsfileenginehandler.cpp qandroidassetsfileenginehandler.h
qandroideventdispatcher.cpp qandroideventdispatcher.h
qandroidinputcontext.cpp qandroidinputcontext.h
@@ -40,8 +41,6 @@ add_qt_plugin(qtforandroid
qandroidplatformtheme.cpp qandroidplatformtheme.h
qandroidplatformwindow.cpp qandroidplatformwindow.h
qandroidsystemlocale.cpp qandroidsystemlocale.h
- DEFINES
- QT_STATICPLUGIN
INCLUDE_DIRECTORIES
${CMAKE_CURRENT_SOURCE_DIR}
${QT_SOURCE_TREE}/src/3rdparty/android
@@ -74,7 +73,6 @@ add_qt_plugin(qtforandroid
#### Keys ignored in scope 1:.:.:android.pro:<TRUE>:
# OTHER_FILES = "$$PWD/android.json"
# _LOADED = "qt_plugin"
-# target.path = "$${target.path}/android"
## Scopes:
#####################################################################