summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/android/CMakeLists.txt
diff options
context:
space:
mode:
authorAmir Masoud Abdol <amir.abdol@qt.io>2023-04-19 12:19:07 +0200
committerAmir Masoud Abdol <amir.abdol@qt.io>2023-04-19 20:09:41 +0200
commitc2fd8241604787de9fd667f16c9a929fd36015c6 (patch)
tree5ca47ad9abbff6e4ac975231a84507f37575146c /src/plugins/platforms/android/CMakeLists.txt
parent70f064f270fa5765f0f00b8eccb45fb7eb68cd9a (diff)
Exclude files from unity build to resolve Android's build
There are several duplicate symbols defined across android source files. For now, excluding the conflicting files allows us to continue working on bringing unity build to CI. I added some explanation and TODO's on what I think can be done for resolving the conflict. Pick-to: 6.5 Task-number: QTBUG-109394 Change-Id: Ic0b31c4ae845c69570ea5dd86316e5a795c166c4 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/plugins/platforms/android/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/android/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/plugins/platforms/android/CMakeLists.txt b/src/plugins/platforms/android/CMakeLists.txt
index f352d5d2ac..632b1c1d42 100644
--- a/src/plugins/platforms/android/CMakeLists.txt
+++ b/src/plugins/platforms/android/CMakeLists.txt
@@ -42,6 +42,18 @@ qt_internal_add_plugin(QAndroidIntegrationPlugin
qandroidplatformtheme.cpp qandroidplatformtheme.h
qandroidplatformwindow.cpp qandroidplatformwindow.h
qandroidsystemlocale.cpp qandroidsystemlocale.h
+ NO_UNITY_BUILD_SOURCES
+ # Conflicting symbols and macros with androidjnimain.cpp
+ # TODO: Unify the usage of FIND_AND_CHECK_CLASS, and similar
+ # macros. Q_JNI_FIND_AND_CHECK_CLASS in `qjnihelpers_p.h`
+ # seems to be doing most of the work already.
+ androidjnimenu.cpp
+ qandroidinputcontext.cpp
+ androidjniaccessibility.cpp
+ qandroidplatformdialoghelpers.cpp
+ # Conflicting JNI classes, and types
+ androidcontentfileengine.cpp
+ qandroidplatformintegration.cpp
DEFINES
QT_USE_QSTRINGBUILDER
INCLUDE_DIRECTORIES