summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/android/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2020-07-08 15:48:46 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2020-07-13 22:07:46 +0200
commitee0198a0183ec2b0cd9ddc6663110cd8e40320aa (patch)
tree74cb7cc1bbd982200480f66dc1057f71f837675b /src/plugins/platforms/android/CMakeLists.txt
parent70f7155fcc20e43f096a029889d8a8117e11f70d (diff)
Move eglconvenience to QtGui
Task-number: QTBUG-83255 Change-Id: I8a008d8906308dd73a0793db5b88d3a1b6fdaf5c Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io>
Diffstat (limited to 'src/plugins/platforms/android/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/android/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/plugins/platforms/android/CMakeLists.txt b/src/plugins/platforms/android/CMakeLists.txt
index d3363de4c7..7fcd42a9bb 100644
--- a/src/plugins/platforms/android/CMakeLists.txt
+++ b/src/plugins/platforms/android/CMakeLists.txt
@@ -3,6 +3,7 @@
#####################################################################
## QAndroidIntegrationPlugin Plugin:
#####################################################################
+qt_find_package(EGL) # special case
qt_internal_add_plugin(QAndroidIntegrationPlugin
OUTPUT_NAME qtforandroid
@@ -46,13 +47,14 @@ qt_internal_add_plugin(QAndroidIntegrationPlugin
${CMAKE_CURRENT_SOURCE_DIR}
${QT_SOURCE_TREE}/src/3rdparty/android
PUBLIC_LIBRARIES
+ EGL::EGL
Qt::Core
Qt::CorePrivate
- Qt::EglSupportPrivate
Qt::Gui
Qt::GuiPrivate
android
jnigraphics
+ EGL::EGL # special case
)
#### Keys ignored in scope 1:.:.:android.pro:<TRUE>: