summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/cocoa/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2020-03-31 19:23:18 +0200
committerTor Arne Vestbø <tor.arne.vestbo@qt.io>2020-06-04 10:39:53 +0200
commit1cee9cc5870b475b141dfa6ad84de2038a28d5b8 (patch)
tree999dfe9b3cb2743271d5475a808cd1c59fd095c1 /src/plugins/platforms/cocoa/CMakeLists.txt
parent9dd8e655cdd26eeaae30645b7fe013d9a696547f (diff)
macOS: Remove QtWidget dependency from platform plugin
The dialog helpers don't depend on widgets themselves, and should be built regardless of whether the widget dialogs are enabled, as these helpers can (and should) be used by other layers, such as Qt Quick. Change-Id: I1c66b474ab2f29748f1256aea90229c51c12a16f Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io>
Diffstat (limited to 'src/plugins/platforms/cocoa/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/cocoa/CMakeLists.txt19
1 files changed, 3 insertions, 16 deletions
diff --git a/src/plugins/platforms/cocoa/CMakeLists.txt b/src/plugins/platforms/cocoa/CMakeLists.txt
index 11f3f99d8d..7a61231509 100644
--- a/src/plugins/platforms/cocoa/CMakeLists.txt
+++ b/src/plugins/platforms/cocoa/CMakeLists.txt
@@ -43,6 +43,9 @@ qt_internal_add_plugin(QCocoaIntegrationPlugin
qnsview.h qnsview.mm
qnswindow.h qnswindow.mm
qnswindowdelegate.h qnswindowdelegate.mm
+ qcocoacolordialoghelper.h qcocoacolordialoghelper.mm
+ qcocoafiledialoghelper.h qcocoafiledialoghelper.mm
+ qcocoafontdialoghelper.h qcocoafontdialoghelper.mm
DEFINES
QT_NO_FOREACH
PUBLIC_LIBRARIES
@@ -110,21 +113,5 @@ qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_sessionmanager
#### Keys ignored in scope 7:.:.:cocoa.pro:TARGET Qt::Widgets:
# QT_FOR_CONFIG = "widgets"
-
-qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_colordialog AND TARGET Qt::Widgets
- SOURCES
- qcocoacolordialoghelper.h qcocoacolordialoghelper.mm
-)
-
-qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_filedialog AND TARGET Qt::Widgets
- SOURCES
- qcocoafiledialoghelper.h qcocoafiledialoghelper.mm
-)
-
-qt_extend_target(QCocoaIntegrationPlugin CONDITION QT_FEATURE_fontdialog AND TARGET Qt::Widgets
- SOURCES
- qcocoafontdialoghelper.h qcocoafontdialoghelper.mm
-)
-
#### Keys ignored in scope 12:.:.:cocoa.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
# PLUGIN_EXTENDS = "-"