summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/cocoa/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2022-10-26 19:32:02 +0200
committerTor Arne Vestbø <tor.arne.vestbo@qt.io>2022-11-15 20:36:17 +0100
commita47c7a98264c85e9ff0bc3e5a42b9554dd20576e (patch)
treed5e38ca7948a87aa657030e2ddc6716926d4606e /src/plugins/platforms/cocoa/CMakeLists.txt
parentda0587c43a611cd5d74119ee4a62d0a8767b4d8e (diff)
macOS: Add dialog helper for native message boxes
The native implementation uses NSAlert, making a best effort to map the QMessageBox properties to the native dialog, falling back to the cross platform non-native dialog if the discrepancy is too big. The initial implementation focuses on the current state of the native dialog helper "protocol", but there's room for improvement here, which would allow even more dialog types and properties to be native. [ChangeLog][macOS] Message boxes such as QMessageBox now follow the platform look and feel by using native dialogs if possible. Change-Id: I4da33f99894194a7b301628cd1fbb44d646ddf18 Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'src/plugins/platforms/cocoa/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/cocoa/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/platforms/cocoa/CMakeLists.txt b/src/plugins/platforms/cocoa/CMakeLists.txt
index c5f71316da..cc4722cb3e 100644
--- a/src/plugins/platforms/cocoa/CMakeLists.txt
+++ b/src/plugins/platforms/cocoa/CMakeLists.txt
@@ -48,6 +48,7 @@ qt_internal_add_plugin(QCocoaIntegrationPlugin
qcocoacolordialoghelper.h qcocoacolordialoghelper.mm
qcocoafiledialoghelper.h qcocoafiledialoghelper.mm
qcocoafontdialoghelper.h qcocoafontdialoghelper.mm
+ qcocoamessagedialog.h qcocoamessagedialog.mm
DEFINES
QT_NO_FOREACH
LIBRARIES