summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/cocoa/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-11-13 15:00:38 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-11-14 09:05:48 +0000
commite9a58ba9e55467f8c69e19dd52c2afa7cbb39529 (patch)
tree0d9d92641192c7bc7ca7c6d451d7d123d80ea6bb /src/plugins/platforms/cocoa/CMakeLists.txt
parent38354d7d6132344a322751c91202109d847771b9 (diff)
Regenerate src/*
Change-Id: I0314b4faa1e4860e86198eea4189987e527dfec2 Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/plugins/platforms/cocoa/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/cocoa/CMakeLists.txt20
1 files changed, 10 insertions, 10 deletions
diff --git a/src/plugins/platforms/cocoa/CMakeLists.txt b/src/plugins/platforms/cocoa/CMakeLists.txt
index 68ae238334..0c76f99790 100644
--- a/src/plugins/platforms/cocoa/CMakeLists.txt
+++ b/src/plugins/platforms/cocoa/CMakeLists.txt
@@ -7,7 +7,7 @@ qt_find_package(Cups PROVIDED_TARGETS Cups::Cups)
## qcocoa Plugin:
#####################################################################
-add_qt_plugin(qcocoa
+qt_add_plugin(qcocoa
TYPE platforms
DEFAULT_IF ${QT_QPA_DEFAULT_PLATFORM} MATCHES cocoa # special case
CLASS_NAME QCocoaIntegrationPlugin
@@ -78,7 +78,7 @@ set(qcocoaresources_resource_files
"images/waitcursor.png"
)
-add_qt_resource(qcocoa "qcocoaresources"
+qt_add_resource(qcocoa "qcocoaresources"
PREFIX
"/qt-project.org/mac/cursors"
FILES
@@ -92,12 +92,12 @@ add_qt_resource(qcocoa "qcocoaresources"
## Scopes:
#####################################################################
-extend_target(qcocoa CONDITION QT_FEATURE_opengl
+qt_extend_target(qcocoa CONDITION QT_FEATURE_opengl
SOURCES
qcocoaglcontext.h qcocoaglcontext.mm
)
-extend_target(qcocoa CONDITION QT_FEATURE_vulkan
+qt_extend_target(qcocoa CONDITION QT_FEATURE_vulkan
SOURCES
qcocoavulkaninstance.h qcocoavulkaninstance.mm
LIBRARIES
@@ -106,7 +106,7 @@ extend_target(qcocoa CONDITION QT_FEATURE_vulkan
Qt::VulkanSupport
)
-extend_target(qcocoa CONDITION QT_FEATURE_accessibility
+qt_extend_target(qcocoa CONDITION QT_FEATURE_accessibility
SOURCES
qcocoaaccessibility.h qcocoaaccessibility.mm
qcocoaaccessibilityelement.h qcocoaaccessibilityelement.mm
@@ -116,7 +116,7 @@ extend_target(qcocoa CONDITION QT_FEATURE_accessibility
Qt::AccessibilitySupport
)
-extend_target(qcocoa CONDITION TARGET Qt::Widgets
+qt_extend_target(qcocoa CONDITION TARGET Qt::Widgets
SOURCES
qpaintengine_mac.mm qpaintengine_mac_p.h
LIBRARIES
@@ -128,7 +128,7 @@ extend_target(qcocoa CONDITION TARGET Qt::Widgets
#### Keys ignored in scope 6:.:.:cocoa.pro:TARGET Qt::Widgets:
# QT_FOR_CONFIG = "widgets"
-extend_target(qcocoa CONDITION TARGET Qt::PrintSupport AND TARGET Qt::Widgets
+qt_extend_target(qcocoa CONDITION TARGET Qt::PrintSupport AND TARGET Qt::Widgets
SOURCES
qcocoaprintdevice.h qcocoaprintdevice.mm
qcocoaprintersupport.h qcocoaprintersupport.mm
@@ -139,17 +139,17 @@ extend_target(qcocoa CONDITION TARGET Qt::PrintSupport AND TARGET Qt::Widgets
Qt::PrintSupport
)
-extend_target(qcocoa CONDITION QT_FEATURE_colordialog AND TARGET Qt::Widgets
+qt_extend_target(qcocoa CONDITION QT_FEATURE_colordialog AND TARGET Qt::Widgets
SOURCES
qcocoacolordialoghelper.h qcocoacolordialoghelper.mm
)
-extend_target(qcocoa CONDITION QT_FEATURE_filedialog AND TARGET Qt::Widgets
+qt_extend_target(qcocoa CONDITION QT_FEATURE_filedialog AND TARGET Qt::Widgets
SOURCES
qcocoafiledialoghelper.h qcocoafiledialoghelper.mm
)
-extend_target(qcocoa CONDITION QT_FEATURE_fontdialog AND TARGET Qt::Widgets
+qt_extend_target(qcocoa CONDITION QT_FEATURE_fontdialog AND TARGET Qt::Widgets
SOURCES
qcocoafontdialoghelper.h qcocoafontdialoghelper.mm
)