summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/eglfs/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Hausmann <simon.hausmann@qt.io>2019-06-05 13:48:02 +0200
committerSimon Hausmann <simon.hausmann@qt.io>2019-06-05 14:20:26 +0000
commitbc9409d85748c7167a9e8e7eec82fa6c9420ea3d (patch)
treea2f431d606578dd67c53b5fba14cdf8611b02e78 /src/plugins/platforms/eglfs/CMakeLists.txt
parent9298033ed6e6e67cce89243f44b7ce77018d0e62 (diff)
Re-generate the CMakeLists.txt and add the prev files
Change-Id: I93ea196bdd5807bccebf81e72332966288a35a4f Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/plugins/platforms/eglfs/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/eglfs/CMakeLists.txt17
1 files changed, 12 insertions, 5 deletions
diff --git a/src/plugins/platforms/eglfs/CMakeLists.txt b/src/plugins/platforms/eglfs/CMakeLists.txt
index 932d07dec2..47b5f3cf64 100644
--- a/src/plugins/platforms/eglfs/CMakeLists.txt
+++ b/src/plugins/platforms/eglfs/CMakeLists.txt
@@ -1,3 +1,4 @@
+# Generated from eglfs.pro.
qt_find_package(EGL) # special case
#####################################################################
@@ -14,8 +15,8 @@ add_qt_module(EglFSDeviceIntegration
api/qeglfsscreen.cpp api/qeglfsscreen_p.h
api/qeglfswindow.cpp api/qeglfswindow_p.h
DEFINES
- QT_EGL_NO_X11
QT_BUILD_EGL_DEVICE_LIB
+ QT_EGL_NO_X11
INCLUDE_DIRECTORIES
api
LIBRARIES
@@ -31,7 +32,7 @@ add_qt_module(EglFSDeviceIntegration
EGL::EGL # special case
)
-#### Keys ignored in scope 2:.:./eglfsdeviceintegration.pro:<NONE>:
+#### Keys ignored in scope 2:.:.:eglfsdeviceintegration.pro:<TRUE>:
# CONFIG = "internal_module" "egl"
# MODULE = "eglfsdeviceintegration"
# _LOADED = "qt_module"
@@ -42,18 +43,22 @@ add_qt_module(EglFSDeviceIntegration
extend_target(EglFSDeviceIntegration CONDITION TARGET Qt::InputSupportPrivate
LIBRARIES
Qt::InputSupportPrivate
+ PUBLIC_LIBRARIES
+ Qt::InputSupport
)
extend_target(EglFSDeviceIntegration CONDITION TARGET Qt::PlatformCompositorSupportPrivate
LIBRARIES
Qt::PlatformCompositorSupportPrivate
+ PUBLIC_LIBRARIES
+ Qt::PlatformCompositorSupport
)
# special case:
# extend_target(EglFSDeviceIntegration CONDITION NOT EGLFS_PLATFORM_HOOKS_SOURCES_ISEMPTY ...
# extend_target(EglFSDeviceIntegration CONDITION NOT EGLFS_DEVICE_INTEGRATION_ISEMPTY ...
-#### Keys ignored in scope 7:.:./eglfsdeviceintegration.pro:use_gold_linker:
+#### Keys ignored in scope 7:.:.:eglfsdeviceintegration.pro:use_gold_linker:
# CONFIG = "no_linker_version_script"
# Resources:
@@ -73,6 +78,7 @@ extend_target(EglFSDeviceIntegration CONDITION QT_FEATURE_opengl
add_qt_plugin(qeglfs
TYPE platforms
+ CLASS_NAME QEglFSIntegrationPlugin
SOURCES
qeglfsmain.cpp
DEFINES
@@ -85,16 +91,17 @@ add_qt_plugin(qeglfs
EGL::EGL # special case
)
-#### Keys ignored in scope 11:.:./eglfs-plugin.pro:<NONE>:
+#### Keys ignored in scope 11:.:.:eglfs-plugin.pro:<TRUE>:
# CONFIG = "egl"
# OTHER_FILES = "$$PWD/eglfs.json"
# PLUGIN_CLASS_NAME = "QEglFSIntegrationPlugin"
+# PLUGIN_TYPE = "platforms"
# _LOADED = "qt_plugin"
## Scopes:
#####################################################################
-#### Keys ignored in scope 12:.:./eglfs-plugin.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
+#### Keys ignored in scope 12:.:.:eglfs-plugin.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
# PLUGIN_EXTENDS = "-"
add_subdirectory(deviceintegration)